Backup of an Oracle database fails with an error "Unknown CORBA exception. Unable to contact the media server. Confirm that the Backup Exec Job Engine service is running on the media server"

記事: 100030379
最終公開日: 2013-05-01
評価: 0 0
製品: Backup Exec

Problem

Backup of an Oracle database fails with an error "Unknown CORBA exception. Unable to contact the media server. Confirm that the Backup Exec Job Engine service is running on the media server"

Error Message

Final error: 0xe0001405 - Unknown CORBA exception. Unable to contact the media server. Confirm that the Backup Exec Job Engine service is running on the media server.
Final error category: Resource Errors

For additional information regarding this error refer to link V-79-57344-5125

Cause

Backup of an Oracle database can fail with the above error if the Backup Exec job engine is not able to communicate with the Oracle database. This can happen if the port specified in the Backup Exec Remote Agent utility on the Oracle server for Oracle backups/restores is in use by any other application on the Backup Exec server.

 

Solution


  To confirm the issue, enable debug logging for the Oracle agent on the Oracle server and check the VXBSA debug log (refer to the related documents section for exact information on how to enable debug logging).

The VXBSA debug log will have the following error:
[6284] CorbaClt: System exception
[6284] CorbaClt: Warning: corba client is unable to connect to corba server at port number 5633 : Please confirm following
[6284] 1) Corba server is running in media server to accept client requests (check bengine log on media server)
[6284] 2) Media server machine configuration - Tools->Options->Network and Security->Custom port number - matches with vxmon machine configuration
[6284] 3) Media server machine can be pinged from this agent machine
[6284]     if it can not be pinged, add entry of media server in etc/hosts file.


To resolve the issue, make sure that port 5633 (the default port used by Backup Exec to backup an Oracle database) is not in use by any other application.

Alternately, change the port used by Backup Exec. To change the port follow the steps given below:

1. On the Oracle server open the Backup Exec Remote Agent Utility and go to the Database Access tab.
2. Select the option " Use a Custom port to connect to the media server during Oracle and DB2 operations."
3. Enter a port number that is not in use and can be used for Oracle backups and click OK.
4. At the following prompt to change to the same port in Backup Exec under Tools-Options-Network- Security, click OK.
5. Restart the Backup Exec Remote Agent Service on the Oracle server.
6. On the Backup Exec server, open Backup Exec and go to Tools-Options-Network- Security.
7. Under custom port Number (Oracle and DB2 Only) select Use a custom port to receive operation requests from the remote system and enter the same port number as entered on the Oracle server.
8. Stop and restart all Backup Exec services and rerun the backup.


Note for Windows 2008 servers:
  
On Windows 2008 servers with the Windows Firewall disabled, port 5633 may not appear to be available or open.
 
Resolution: 
  • Enable the Windows Firewall.
  • Edit the firewall policy to enable inbound/outbound TCP traffic for port 5633.
  • Disable the Windows Firewall, if desired.


Note for 3rd Party Firewalls:
 
In some environments a 3rd party firewall is activated and even after adding port 5633 the Oracle backup are still failing with the above mentioned error.
 
Resolution: 
  • Edit the firewall settings and add "oracle.exe" to the exclusions.
Note for IPv6 related issues:
 
In some environments the above issue is seen and caused by an address resolution related issue caused by specific IPv6 / IPv4 configurations.
 
Resolution: 
  • Add the IPv4 address to the HOST files of the Oracle respectively Backup Exec Media server.
Please note that Oracle agent does not support IPv6 protocol. Disabling IPv6 also resolve this issue.
 

 

Was this content helpful?