Problem
Backup Exec Installation Wizard Opens and disappears immediately
Note: This issue is observed in multiple versions of Backup Exec. The Event log details may vary in version numbers. 21.0.620.0, 22.x, and 23.x.
Error
Error during Installation Launch :_Setup has stopped working. A problem caused the program to stop working correctly. Please Close the program.
Error reported in Backup Exec installation log (C:\ProgramData\Veritas\Backup Exec\Logs\BKUPINSTxx.htm).
ERROR: Installation failed with error -532462766. GetLastError = :0
Error in Application Event Log:
Source: Application Error
Event ID: 1000
Faulting application name: _Setup.exe, version: 21.0.620.0,, time stamp: 0x61e0384a
f9
Faulting module name: KERNELBASE.dll, version: 10.0.17763.3650, time stamp: 0x62549b
Exception code: 0xe0434352
Fault offset: 0x0000000000034859
Faulting process ID: 0x17fc
Faulting application start time: 0x01d8f9c4a660c8f0
Faulting application path: X:\BE\WinNT\Install\BEx64\Install\_Setup.exe
Faulting module path: C:\Windows\System32\KERNELBASE.dll
Report ID: e7e7b408-3f6b-4562-a7ad-6ac9a3ba9919
Faulting package full name:
Faulting package-relative application ID:
Application: _Setup.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.Security.SecurityException
at IFrameSDK._Setup.Setup.Main(System.String[])
Faulting application name: _Setup.exe, version: 2x.x.xxxx.x, time stamp: 0x6343b773
Faulting module name: KERNELBASE.dll, version: 10.0.20348.1787, time stamp: 0x99873638
Exception code: 0xe0434352
Fault offset: 0x000000000003ef5c
Faulting process id: 0x1058
Faulting application start time: 0x01d99ecd9b933757
Faulting application path: X:\BE\WINNT\INSTALL\BEx64\Install\_Setup.ex
Event Type: Error
Source: .NET Runtime
Event ID: 1026
Description: Application: _Setup.exe Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.Security.SecurityException
Stack:
at a.a(System.String[])
Cause
Zone Identifier may be contained in Backup Exec installer files.
Solution
1. To delete or unblock the Zone Identifier - Right click the Backup_Exec zip or ISO file,
Choose Properties and Select unblock on the zip file property.
2. Extract from the zip and ensure ISO file is also unblocked ( as shown in the above screenshot).
3. Run the Backup Exec installation and it should work.
Alternate Solution:
NOTE: In some situations, the file properties of either the zip or the iso file may not show the Unblock button, yet the install fails with the same behavior and event. In those situations, use the following steps to unblock the Backup Exec iso:
1. Extract the Backup Exec ISO from the zip file to a folder on the Backup Exec server.
2. Open Windows Powershell as Administrator on the Backup Exec server
3. Type the following into Powershell with the full path name and file name of the Backup Exec ISO:
unblock-file -path "C:\Users\Administrator.Domain\Downloads\BE-DVD-1193.1605.iso"
3. Run the Backup Exec installation and it should work.