The Backup Exec Device and Media Service will not start and "Event id 58068, the database recovery has failed. Refer to the database recovery log for details" occurs.

Article: 100022440
Last Published: 2019-10-31
Ratings: 0 1
Product(s): Backup Exec

Problem

The Backup Exec Device and Media Service will not start and "Event id 58068,  the database recovery has failed. Refer to the database recovery log for details" occurs.

 

Error Message

The Application Event shows Event ID 58068 with below description;
 
The Backup Exec Device and Media Service could not start because the database recovery has failed.  Refer to the database recovery log for details. 
 
UMI Code: V-379-58068
 

Cause

Backup Exec database is not attached to the SQL instance used by Backup Exec. 

 

Solution

   Warning: Incorrect use of the Windows registry editor may prevent the operating system from functioning properly. Great care should be taken when making changes to a Windows registry. Registry modifications should only be carried-out by persons experienced in the use of the registry editor application. It is recommended that a complete backup of the registry and workstation be made prior to making any registry changes.
 
1. Navigate to the  HKEY_Local_Machine/Software/Symantec/Backup Exec For Windows/Backup Exec/Server key in the registry editor .The string value of LastknownSQLDB must refer to the BEDB_Dat.mdf location.
 
 
 
2. Check the dbrecover.log file in (Drive):\Program Files\Veritas\Backup Exec\Logs directory.  It may show:
 
GetDatabaseStatus status=NOT EXIST
Database BEDB does not exist
File Exist Check: \\SERVERNAME\C$\Program Files\Veritas\Backup Exec\Data\BEDB_dat.mdf
File Exist: FALSE
File Exist Check: \\SERVERNAME\C$\Program Files\Veritas\Backup Exec\Data\BEDB.bak
File Exist: FALSE
File Exist Check: \\SERVERNAME\C$\Program Files\Veritas\Backup Exec\Data\BEDB_dat.bak
File Exist: FALSE
Deinitialize...
 
3. Verify that the file BEDB_Dat.mdf is present in that location (Drive):\Program Files\Veritas\Backup Exec\Data\.
 
4. Run a UDL test to check whether connection to the Backup Exec SQL Instance is available. Please follow the below article to run the UDL test. You may not see the BEDB listed under the instance, but confirm the connection to Master succeeds.
 
5. Follow the steps given in the below article to attach the Backup Exec Database Files to the instance.
 
6. After attaching the Database, perform the UDL test again, and confirm the BEDB test succeeds.
 
7. Start the Device and Media Service.
 

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