nbdb_ping saying the database NBDB is not available

Article: 100024706
Last Published: 2012-07-31
Ratings: 3 2
Product(s): NetBackup & Alta Data Protection

Problem

EMM Server is down and while executing nbdb_ping command it reporting that the NetBackup database (NBDB) is not available.

UNIX/Linux: /usr/openv/db/bin/nbdb_ping
Windows: install_path\NetBackup\bin\nbdb_ping

 

Error Message

nbdb_ping
Database [NBDB] is not available.

 

Cause

The vxdbms.conf file is missing port and data entries.

UNIX/Linux: /usr/openv/db/data/vxdbms.conf
Windows: install_path\NetBackupDB\data\vxdbms.conf

 

Troubleshooting:

  • Checked disk space for the volume containing the install directory. (This was fine.)
  • Since the master server is clustered, also checked the shared drive for EMM. (This was also fine.)
  • Tried command nbdb_admin -auto_start NONE. (Received the error "can not read data line in vxdbms.conf file".)
  • Checked vxdbms.conf file. (Found file is shorter than expected.)
  • Compared the configuration with a known good, similar machine. (Found there is no port, data, index, and tlog entry.)

 

Solution

Option 1: The create_nbdb command with the -config_only option creates the vxdbms.conf file from the information available in the bp.conf file.

UNIX/Linux: /usr/openv/db/bin/create_nbdb -config_only
Windows: install_path\NetBackup\bin\create_nbdb -config_only

Note: Some entries in existing vxdbms.conf file can be updated via nbdb_admin command, for additional information see the NetBackup Commands Guide.

UNIX/Linux: /usr/openv/db/bin/nbdb_admin
Windows: install_path\NetBackup\bin\nbdb_admin

 

Option 2: Manually edited the vxdbms.conf file and create the missing entries:

VXDBMS_NB_PORT = 13785
VXDBMS_NB_DATA = <PATH_TO_DB_data>
VXDBMS_NB_INDEX = <PATH_TO_DB_data>
VXDBMS_NB_TLOG = <PATH_TO_DB_data>

Note: Suggest referencing a known good server with the same configuration to compare with, otherwise open a case with support for additional guidance.

 

After the configuration has been updated and NetBackup services are restarted, the nbdb_ping command should now show:

Database [NBDB] is alive and well on server [NB_<masterservername>].

 

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