HP Server Management Agents ソフトウェアがインストールされているサーバーでテープへのバックアップを行うと、「不明なエラーが発生しました。」が発生する

Article: 100036450
Last Published: 2020-12-03
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Product(s): Backup Exec

問題

HP Server Management Agents ソフトウェア、または HP StorageWorks 管理ソフトウェアのいずれか一方でもインストールされているサーバーでテープへのバックアップを行うと、「不明なエラーが発生しました。」が発生します。

エラーメッセージ

0xe00084f4 - 不明なエラーが発生しました。
Completed status: Failed
最終エラー: 0xe00084f4 - 不明なエラーが発生しました。
最終エラーカテゴリ: システムエラー

このエラーについて詳しくはリンクを参照してください。V-79-57344-34036

UMI コード: V-79-57344-34029

原因

SCSISTAT_QUEUE_FULL エラーが発生する原因は多くの場合、HP Insight Server Management Agent ソフトウェアまたは HP StorageWorks VDS Hardware Providers for MSA Disk Arrays ソフトウェアとの競合です。この状態を確認するには、TRACER.EXE を実行して、障害が発生したハードウェアで SCSI 追跡を実行します。TRACER.EXE の使用方法については、関連文書 (Related Articles) を参照してください。
 
WRITE6 コマンドで次の SCSISTAT_QUEUE_FULL エラーを確認できます。(図 1)
 
図 1
  
 

Driver Result として STATUS_DEVICE_NOT_CONNECTED エラーが発生する場合もあります。(図 2)

図 2
STATUS_DEVICE_NOT_CONNECTED

 

STATUS_DEVICE_NOT_CONNECTED エラーが発生すると、adamm.log に Device error 1167 が記録されます。

注意: adamm.log の SCSI 追跡には Driver Result が記録されません。

[7832] 11/12/12 00:18:44.225 DeviceIo: 04:07:00:00 - Device error 1167 on "\\.\Tape0", SCSI cmd 4d, 1 total errors
[3312] 11/12/12 00:19:50.400 PvlDrive::DisableAccess() - ReserveDevice failed, offline device
       Drive = 1023 "TapeDRV1"
       ERROR = 0x0000001F (ERROR_GEN_FAILURE)

[3312] 11/12/12 00:19:50.400 PvlDrive::UpdateOnlineState()
       Drive = 1023 "TapeDRV1"
       ERROR = The device is offline!
...

...

SCSI: ==========================================================================
SCSI: CDB 04:07:00:00 Start 00:18:44.225 End 00:18:44.225 Duration 0.000000
SCSI: Function                                SRB_FUNCTION_EXECUTE_SCSI
SCSI:
SCSI: Raw CDB
SCSI: 4D 00 71 00 00 00 00 00 24 00                   M.q.....$.
SCSI:
SCSI: CDB Operation                           LOG_SENSE
SCSI:  LUN                                    0
SCSI:  PPC                                    False
SCSI:  SP                                     False
SCSI:  Parameter pointer                      0
SCSI:  Alloc length                           36
SCSI:  Control                                0x00
SCSI: Data
SCSI: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
SCSI: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
SCSI:
SCSI:
SCSI: Capture dropped 2838409 events
SCSI: Capture dropped 6059 events
SCSI: Capture dropped 3314492 events
[3312] 11/12/12 00:19:50.697 End dump of device SCSI history

解決方法

1.  最新バージョンの HP Insight エージェントをインストールし、バックアップをもう一度テストします。
 
2.  Windows Server 2003 を使用している場合は、最新の StorPort ドライバにアップグレードします。 
 
参照: https://support.microsoft.com/kb/935640 。バックアップをもう一度実行します。 
 
3.  StorageWorks Library and Tape Tools (L&TT) を実行し、100 GB のバックアップをテストします。 
 
A. 最新バージョンの L&TT をダウンロードしてインストールします。  https://www.hp.com/support/tapetools
 
B. Backup Exec サービスを停止します。 
 
C. スクラッチテープをドライブに挿入します。   * ***重要: HP L&TT テストでテープ上のデータが上書きされるので、スクラッチテープを使う必要があります。
 
D. [By Product]タブで、テストしたいドライブを選択します。 
 
E. ウィンドウ上部の[TEST]アイコンをクリックします。
 
F. [Test Group]フィールドで[READ/WRITE]テストにドリルダウンします。
 
G. [Options]ボタンをクリックします。
 
H. [Options] ウィンドウが開きます。[Amount of data written/read in each phase]をダブルクリックし、データ量を 100 GB に変更できます。
 
100 GB のテストデータがドライブに書き込まれます。テストが失敗する場合は、HP 社のテクニカルサポートに問い合わせ、トラブルシューティングを依頼してください。 

4. BusyRetryCount を増やし、バックアップをもう一度テストします。

BusyRetryCount を増やす方法については、 000082909  (英語) を参照してください。

5. HP マネジメントエージェントとサービスを無効にします。
 
WMI Storage Service を無効にします。(サーバーの再起動が必要です。)

[コントロールパネル]、[HP マネジメントエージェント]で[サービス]タブを選択し、[SCSI 情報]と[SAS 情報]を[無効なエージェント]列に移動します。 

[ストレージ]タブで以下を無効にします。
Fibre Agent Tape Support
Smart Array Agent Tape Support
SAS Agent Tape Support
Smart Array Performance Monitoring

バックアップジョブを再試行します。まだ失敗する場合は、[パフォーマンスモニタ]を[無効なエージェント]列に移動して、バックアップをもう一度実行します。 

6. 次の HP サービスを無効にし、サーバーを再起動してバックアップをもう一度テストします。  

   -  HP Insight Server Agents
   -  HP Insight Storage Agents
   -  HP Insight Foundation Agents
   -  HP WMI Storage Providers サービス
 
注意: 4 つのサービスがすべて存在するとは限りません。テープドライブ用に更新したシマンテックのドライバと競合する、上記のサービスのみを無効にしてください。
 
7.  HP StorageWorks VDS Hardware Providers for MSA Disk Arrays ソフトウェアをアンインストールして、バックアップをもう一度テストします。  

このソフトウェアは HP ストレージサーバーにデフォルトでインストールされています。[コントロールパネル]、[プログラムのアンインストール]でこのソフトウェアが表示されない場合もあります。HP 社テクニカルサポートに連絡して、このプログラムをアンインストールしてください。

8.  HP Insight Manager ソフトウェアをアンインストールして、バックアップをもう一度テストします。 

9. 使用していないサードパーティのバックアップソフトウェアがある場合は、テープデバイスがブロックされたり、競合が発生することがあります。そのようなソフトウェアをアンインストールして、バックアップをもう一度テストします。

注意 : HP サービスを無効にしたり、HP ソフトウェアを削除してエラーが解決した場合は、HP 社のテクニカルサポートにお問い合わせください。
 

 

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