問題
バックアップ選択リストで SQL Server インスタンスを展開しようとすると失敗します。以前に作成されたバックアップは、「リソースに接続できません」というエラーで失敗します。または 「Microsoft SQL Server が実行されていないか、ネットワーク接続によるアクセスに問題があるようです」というエラーで失敗します。
もしくは
SQL バックアップの選択項目を展開できますが、バックアップジョブが 「SQL Server への接続の試行に失敗しました。ログオンアカウントのクレデンシャルが無効か、ログオンアカウントが不適切なリソースに適用されている可能性があります」というエラーで失敗します。
エラーメッセージ
SQL Server への接続の試行に失敗しました。ログオンアカウントのクレデンシャルが無効か、ログオンアカウントが不適切なリソースに適用されている可能性があります。
エラーコード: 0xe000848c - リソースに接続できません。選択したリソースが存在してオンラインであることを確認し、再度実行してください。サーバーまたはリソースが存在しない場合は選択から削除してください。
UMI Code: V-79-57344-33932
エラー コード: 0xe0009415 - Microsoft SQL Server が実行されていないか、ネットワーク接続によるアクセスに問題があるようです。
UMIコード:V-79-57344-37909
V-79-57344-893 - スナップショットテクノロジ: "<sqlserver>\<instance>" での初期化に失敗しました。スナップショットテクノロジが使われています: Microsoft ボリュームシャドウコピーサービス (VSS)。スナップショットテクノロジエラー(0xE000037D): SQL Server への接続の試行に失敗しました。ログオンアカウントのクレデンシャルが無効か、ログオンアカウントが不適切なリソースに適用されている可能性があります。
原因
- Backup Exec アカウントが SQL インスタンスの正しい資格情報を持っていないことが原因である可能性があります。
もしくは
- SQL Server (INSTANCE NAME) サービスが実行されていないか、SQL サーバーで無効な状態になっています。
解決策
1. Backup Exec サービスアカウントに SQL サーバーに対する次のサーバーロールと権限があることを確認します。
- dbcreator
- securityadmin
- serveradmin
- sysadmin
技術情報 100019906 を参照してください。
注: 代替ログオンアカウントを Backup Exec ログオンアカウントに追加し、定義済みの「システムログオンアカウント」または「Backup Exec サービスアカウント」とは異なる資格情報で SQL サーバーをバックアップするように指定できます。 SQL サーバーは、同じドメイン、別のドメイン、またはワークグループに配置できます。 ログオンアカウントには、サーバーに対するローカル管理者権限と、SQL インスタンスに対する権限が必要です。 [バックアップとリストア] タブで、SQL サーバーの資格情報を代替ログオンアカウントに変更します。
2. Backup Exec アカウントを SQL サーバーのローカル管理者グループに追加します。
3. UDL テストを使用して Backup Exec サーバーからアクセスできることを確認します。
技術情報 100016039 を参照してください。
4. SQL Server (INSTANCE NAME) サービスが実行中であり、SQL サーバー上で無効状態になっていないことを確認します。